Foro XCockpits

TeamSpeak para X-IVAP

Ver el tema anterior Ver el tema siguiente Ir abajo

TeamSpeak para X-IVAP

Mensaje  gengispala el Lun Nov 29, 2010 7:54 pm

Siguiendo el foro y todas vuestras (valiosísimas) recomendaciones y explicaciones, ya tengo instalado el x-plane, los escenarios, el X-Ivap para volar en IVAO, el teamspeak......... peeeeeeero.......... (siempre tiene que haber un pero) no hay manera de configurar éste último, el teamspeak, para poder hablar y escuchar por los auriculares-micro.

Tengo un Logitech con conexión USB. Entiendo que debo meterme, dentro del teamspeak, en
-settings
- options
- Pestaña Sound Devices

Una vez ahí "imagino" que deberé pulsar la opción
-other

e indicar la ruta del driver de sonido de mis auriculares, correcto?

Pues bien, cómo podría saber yo esa ruta?????

Saludos y gracias de antemano.

gengispala

Mensajes : 12
Fecha de inscripción : 28/11/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  atr72 el Lun Nov 29, 2010 9:52 pm

No he instalado el X-IVAP, y ahora mismo no tengo tiempo para hacerlo, pero me resulta sospechoso ese "other". ¿Has comprobado si el sistema detectó tus auriculares-micro?
En primer lugar comprueba en Sistema->Preferencias->Sonido para ver si aparecen todos los dispositivos de sonido que tengas.

atr72

Mensajes : 46
Fecha de inscripción : 07/10/2010
Localización : Canarias

Ver perfil de usuario http://atr72.esimat.es

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  gengispala el Lun Nov 29, 2010 10:19 pm

Sí, el sistema lo reconoce sin problema. Oigo música, veo pelis.... todo.

Sigo buscando solución, pero esto sí que no parece fácil.

gengispala

Mensajes : 12
Fecha de inscripción : 28/11/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  josf el Mar Nov 30, 2010 12:31 am

agregame al MSN que te ayudo, y luego posteamos la solucion aca...
en mi perfil esta mi correo Wink

josf
Moderador
Moderador

Mensajes : 300
Fecha de inscripción : 10/06/2010
Localización : Uruguay

Ver perfil de usuario http://www.destroyer.webcindario.com

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  eperezsa el Mar Nov 30, 2010 2:20 am

Pues con la iglesia hemos topado, compañero.

El sistema de sonido de Linux esta basado en una cagada que se llama pulseaudio que funciona muy bien ... si no le metes en problemas y el RS es un problema.

Ademas de este hay otro problema y es que TeamSpeak captura el sistema de sonido principal del sistema (tu tarjeta) y se la queda para el por lo que si tienes TS no tendrás otros sonidos, incluidos los del avion. Por lo menos eso ocurre en Ubuntu Linux (no tengo razón para pensar que en otros no sea asi).

Para solucionar el problema del TS que se apodera de todo el sistema de sonido (en modo exclusivo por un error de programacion primigenio):

a) debes pinchar un dispositivos USB tipo micro-auriculares todo-en-uno para que sean un dispositivo aparte en tu sistema, o

b) hacerte con otra tarjeta de sonido (en USB o pinchada en PCI) para lo mismo, que sea otro dispositivo de sonido

Yo tengo las dos soluciones funcionando y uso los cascos cuando la familia esta durmiendo o el conjunto de la segunda tarjeta (en mi caso USB) con microfono y speakers baratos (asi simulan el sonido de la radio). tongue

Esperemos que solo sea identificar el dispositivo y configurarlo como indicas ya que tienes un logitech usb, luego estas en la opción a).

Ahora, dime que instalación tienes y vemos posibles soluciones. Lanza estos comandos en una consola para ver que tienes configurado en tu sistema de sonido (no hace falta root) ... asegurate que tienes el logitech conectado:

$ lspci
$ cat /proc/asound/cards
$ cat /proc/asound/modules
$ cat /proc/asound/devices
$ aplay -l
$ arecord -l

El otro problema, el del "pulseaudio" y para ir adelantando trabajo, desinstalalo y ponte el ALSA de toda la vida. Hay docenas de paginas indicando que y como hacerlo. Esta te puede valer:

[Tienes que estar registrado y conectado para ver este vínculo]

Si quieres no procedas todavia y esperamos a ver si algun otro linuxero tiene menos problemas de los que he tenido yo y sabe de otras soluciones.

Ya me contaras.

Saludos

eperezsa

Mensajes : 32
Fecha de inscripción : 06/12/2009
Edad : 48
Localización : Madrid

Ver perfil de usuario

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  gengispala el Mar Nov 30, 2010 3:00 pm

Ahí tienes la información de mi sistema, según ha aparecido con la línea de comandos que me indicaste:

00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4
00:1a.1 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5
00:1a.2 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #6
00:1a.7 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1
00:1c.3 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 4
00:1c.4 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 5
00:1c.5 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 6
00:1d.0 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1
00:1d.1 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2
00:1d.2 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3
00:1d.7 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 90)
00:1f.0 ISA bridge: Intel Corporation 82801JIR (ICH10R) LPC Interface Controller
00:1f.2 IDE interface: Intel Corporation 82801JI (ICH10 Family) 4 port SATA IDE Controller #1
00:1f.3 SMBus: Intel Corporation 82801JI (ICH10 Family) SMBus Controller
00:1f.5 IDE interface: Intel Corporation 82801JI (ICH10 Family) 2 port SATA IDE Controller #2
01:00.0 VGA compatible controller: nVidia Corporation GT200 [GeForce GTX 260] (rev a1)
03:00.0 SATA controller: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 02)
03:00.1 IDE interface: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 02)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
06:06.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
gengispala@gengispala-EP45-DS5:~$ cat /proc/asound/modules
0 snd_hda_intel
1 snd_usb_audio
gengispala@gengispala-EP45-DS5:~$ cat /proc/asound/devices
2: : timer
3: : sequencer
4: [ 0- 2]: digital audio capture
5: [ 0- 1]: digital audio playback
6: [ 0- 1]: digital audio capture
7: [ 0- 0]: digital audio playback
8: [ 0- 0]: digital audio capture
9: [ 0- 2]: hardware dependent
10: [ 0] : control
11: [ 1- 0]: digital audio playback
12: [ 1- 0]: digital audio capture
13: [ 1] : control
gengispala@gengispala-EP45-DS5:~$ aplay -l
**** Lista de PLAYBACK dispositivos hardware ****
tarjeta 0: Intel [HDA Intel], dispositivo 0: ALC889A Analog [ALC889A Analog]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 0: Intel [HDA Intel], dispositivo 1: ALC889A Digital [ALC889A Digital]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 1: Headset [Logitech USB Headset], dispositivo 0: USB Audio [USB Audio]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
gengispala@gengispala-EP45-DS5:~$ arecord -l
**** Lista de CAPTURE dispositivos hardware ****
tarjeta 0: Intel [HDA Intel], dispositivo 0: ALC889A Analog [ALC889A Analog]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 0: Intel [HDA Intel], dispositivo 1: ALC889A Digital [ALC889A Digital]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 0: Intel [HDA Intel], dispositivo 2: ALC889A Analog [ALC889A Analog]
Subdispositivos: 2/2
Subdispositivo #0: subdevice #0
Subdispositivo #1: subdevice #1
tarjeta 1: Headset [Logitech USB Headset], dispositivo 0: USB Audio [USB Audio]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
gengispala@gengispala-EP45-DS5:~$


Ahí es "na", jeje.

gengispala

Mensajes : 12
Fecha de inscripción : 28/11/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  eperezsa el Vie Dic 03, 2010 1:50 pm

Vale, pues esta claro.

Tienes los dos sistemas reconocidos por el kernel y sin problemas (ni solapados, ni montados) por lo que debes poner el sonido del avión, peliculas, musica, etc. como lo tienes en el dispositivo '0'. Eso ahora mismo te esta funcionando, asi que ni tocarlo.

Y en el dispositivo '1' tienes reconocido el USB, asi que configura el TeamSpeak en el "/dev/sound/dsp1" y te funcionará sin problemas. Si no sabes como hacerlo, me comentas, pero es como dices en tu primer mensaje .... ahora mismo estoy en el curro y no tengo acceso a TS. Es la tercera opción de la configuracion (la primera es el defecto, que no te funcionará por corresponder al '0', la segunda other tampoco ya que no tienes segunda tarjeta, asi que es la tercera donde escribes a mano lo que te he comentado).

/dev/sound/dsp1

[EDITADO: por si no te funciona y lo tienes "linkado", prueba con la forma ln => /dev/dsp1, aunque deberia ser lo mismo]

Lo que no vas a poder hacer es utilizar el TeamSpeak por el dispositivo '0' es decir, por donde "salen" los sonidos del sistema, sencillamente, no te va a funcionar el micro. No te pegues con ello, no hay solución.

¿Sigues con pulseaudio? Si realmente no tienes otros problemas con el sonido, no lo desinstales, pero en cuanto empieces a tenerlos, ya sabes lo que tienes que hacer. Yo es lo primero que hago cuando instalo un UBUNTU y no he tenido ya más problemas.

Disculpa la tardanza en contestar, ... Sad

Saludos

eperezsa

Mensajes : 32
Fecha de inscripción : 06/12/2009
Edad : 48
Localización : Madrid

Ver perfil de usuario

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  gengispala el Sáb Dic 04, 2010 6:36 pm

Pues nada. He probado lo que me has comentado y nada, sigue sin funcionar.

No te preocupes por la tardanza, acabo de ser papá hace dos días (el tío no me pidió autorización ni para rodadura, despegó sin más, jeje)

Cuando vuelva a casa seguiré probando.

Saludos a todos.

gengispala

Mensajes : 12
Fecha de inscripción : 28/11/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  eperezsa el Dom Dic 05, 2010 11:56 am

Prueba arrancar el ordenador, sin lanzar nada de nada ... sal del Skype y de los programas de musica, TV, de todo ... y lanza el TS. Prueba todas las combinaciones de /dev/dsp:

/dev/dsp
/dev/dsp0
/dev/dsp1

Otra opción. Lanza el teamspeak manualmente en una consola y pon los mensajes que te tira.

Y otra más. Lanza el teamspeak con la opción "aoss" por delante, es decir:

$ aoss teamspeak

Y luego pruebas los dispositivos de sonido como arriba. Seguramente te funciones a saltos. Por cierto, que sabes como se prueba, ¿no? ... menu SETTINGS luego SOUND INPUT/OUTPUT SETTINGS y luego pulsa en ACTIVATE LOCAL TEST. Imagino que habrás definido una tecla para pulsar y comenzar a hablar y que cuando la pulsas se te ilumina el canal correspondiente ... asumo que todo esto lo conoces. 8-)

PD: Se me olvidaba, ¿has confirmado que tiene los dispositivos /dev/dsp? Ya sabes:

$ ls -la /dev/dsp*

Saludos

eperezsa

Mensajes : 32
Fecha de inscripción : 06/12/2009
Edad : 48
Localización : Madrid

Ver perfil de usuario

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  eperezsa el Dom Dic 05, 2010 12:01 pm

Ah! ... y enhorabuena por tu paternidad

Si necesitas manuales de ese asunto tambien tengo dos, y ademas uno de cada modelo (niño y niña) ... asi que ya sabes, pregunta, pregunta ... jajajajajaja

Saludos

eperezsa

Mensajes : 32
Fecha de inscripción : 06/12/2009
Edad : 48
Localización : Madrid

Ver perfil de usuario

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  Gonzalo Martínez el Vie Mar 25, 2011 10:42 pm

Alguno, habeis probado el nuevo TS, por lo que he leido por la red, ya no dan soporte para el TS2
Saludos

Gonzalo Martínez

Mensajes : 348
Fecha de inscripción : 27/10/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  737Dragon el Vie Mar 25, 2011 11:57 pm

Gonzalo yo tengo reuniones , y ademas esta semana, en el TS , ..a q te refires con lo de q no hay soporte?'??


------------------------------------------------------------------------------------------

---" Si quieres algo para hoy, y empiezas mañana, pasado, tendras una mierda, hecha ayer....es mejor pensar y despues fabricar...para no tener q inventar como tirarlo... [Tienes que estar registrado y conectado para ver esa imagen] " -- . Dragun Gundra



[Tienes que estar registrado y conectado para ver esa imagen]


[b]Saludos
Oscar C
[/b]

737Dragon

Mensajes : 1433
Fecha de inscripción : 26/10/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  Gonzalo Martínez el Sáb Mar 26, 2011 8:29 pm

Que una vez que este totalmente integrado el TS3, iran dejando de dar soporte técnico al TS2, vamos si estas mas interesado, buscaré por donde creo que estaba esa informacion y te la paso.
Saludos

Gonzalo Martínez

Mensajes : 348
Fecha de inscripción : 27/10/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  gengispala el Dom Mar 27, 2011 7:00 am

Antes de nada, mis disculpas por la tardanza. He estado un poco liado y con lo pesado que me puse en el foro quisiera dar las gracias.

Gracias "eperezsa" por tu ayuda, pero de momento, no hay manera. Sólo me quedaría este tema del teamspeak para poder volar en Ubuntu (es casi lo único que me queda por hacer en linux, porque por lo demás me he convertido en un "ubunteriano", esto de linux ha sido un descubrimiento para mi.).

Seguiré probando. Si encontrara la solución os la comunico.

Saludos

gengispala

Mensajes : 12
Fecha de inscripción : 28/11/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  737Dragon el Dom Mar 27, 2011 12:04 pm

Gonzalo Martínez escribió:Que una vez que este totalmente integrado el TS3, iran dejando de dar soporte técnico al TS2, vamos si estas mas interesado, buscaré por donde creo que estaba esa informacion y te la paso.
Saludos

...siempre es bueno saber mas...gracias majo


------------------------------------------------------------------------------------------

---" Si quieres algo para hoy, y empiezas mañana, pasado, tendras una mierda, hecha ayer....es mejor pensar y despues fabricar...para no tener q inventar como tirarlo... [Tienes que estar registrado y conectado para ver esa imagen] " -- . Dragun Gundra



[Tienes que estar registrado y conectado para ver esa imagen]


[b]Saludos
Oscar C
[/b]

737Dragon

Mensajes : 1433
Fecha de inscripción : 26/10/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  josf el Vie Abr 08, 2011 10:59 pm

Hola, no me leí todo el post, me guío por el título.
Pega este código en la consola y al rato ya estas hablando por TS 2 y volando y funcionando con Xivap...

sudo aptitude install teamspeak-client


[Tienes que estar registrado y conectado para ver esa imagen]
[Tienes que estar registrado y conectado para ver este vínculo]

josf
Moderador
Moderador

Mensajes : 300
Fecha de inscripción : 10/06/2010
Localización : Uruguay

Ver perfil de usuario http://www.destroyer.webcindario.com

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  737Dragon el Sáb Abr 09, 2011 1:01 pm

josf escribió:Hola, no me leí todo el post, me guío por el título.
Pega este código en la consola y al rato ya estas hablando por TS 2 y volando y funcionando con Xivap...

sudo aptitude install teamspeak-client

como?¿?¿¿?¿¿?¿ un poco mas de explicacion josf


------------------------------------------------------------------------------------------

---" Si quieres algo para hoy, y empiezas mañana, pasado, tendras una mierda, hecha ayer....es mejor pensar y despues fabricar...para no tener q inventar como tirarlo... [Tienes que estar registrado y conectado para ver esa imagen] " -- . Dragun Gundra



[Tienes que estar registrado y conectado para ver esa imagen]


[b]Saludos
Oscar C
[/b]

737Dragon

Mensajes : 1433
Fecha de inscripción : 26/10/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  josf el Sáb Abr 09, 2011 5:48 pm

Ese es el código para instalar el Team speack 2 en Ubuntu al menos...
Código:
sudo aptitude install teamspeak-client

Lo escribis en la consola.
Pones la contraseña de Administrador
y se comienza a instalar.
Al cabo de haber terminado, aparecerá el Icono del Team Speack en el menu de internet.

Con esto instalado, el simlador y el Xivap.
Ya no deberían haber misterios.

___________________________________________
De manera opcional, si el Xivap no maneja automaticamente al TS2 (Team Speak 2)
Podemos configurar todo manual mente creando un servidor cone stos datos:

Para Europa:
Server Addres: 188.40.64.175
Callsing, la matricula que usen en el momento:
Usuario: ID de IVAO
Password: IVAP Pasword


[Tienes que estar registrado y conectado para ver esa imagen]

Aqui les dejo la lista de Servidores:
[Tienes que estar registrado y conectado para ver esa imagen]




[Tienes que estar registrado y conectado para ver esa imagen]
[Tienes que estar registrado y conectado para ver este vínculo]

josf
Moderador
Moderador

Mensajes : 300
Fecha de inscripción : 10/06/2010
Localización : Uruguay

Ver perfil de usuario http://www.destroyer.webcindario.com

Volver arriba Ir abajo

Re: TeamSpeak para X-IVAP

Mensaje  Contenido patrocinado Hoy a las 2:47 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.